US Extract API responding slowly
Incident Report for SmartyStreets
Postmortem

During a routine password rotation process, various internal passwords relative to the US Extract API were rotated. However, the new passwords were not properly updated within the running US Extract API instances which caused them to return a “401 Unauthenticated” response to callers.

We have added more monitoring around this to process to prevent this in the future and we have identified and are in the process of adding monitoring around other processes that could potentially suffer from the same kind of issue.

Posted 6 months ago. Apr 19, 2019 - 23:02 UTC

Resolved
The issue was resolved earlier. We will publish a postmortem shortly.
Posted 6 months ago. Apr 19, 2019 - 03:32 UTC
Update
We have resolved the issue and are monitoring the US Extract API. All systems operational.
Posted 6 months ago. Apr 18, 2019 - 23:57 UTC
Investigating
We are diagnosing why our US Extract API is responding slowly. We will publish updates as soon as we more information.
Posted 6 months ago. Apr 18, 2019 - 23:16 UTC
This incident affected: US Extract API (us-east, us-central, us-west).